[tvOS] vu+TV App (AppleTV) Support Thread

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • das muss nicht bedeuten, dass die PIcon-URLs von OpenWebIF übertragen werden. Ich muss mir das anschauen, kann ich aber erst machen, wenn ich oATV 7 installiert habe.
    • @jabbela

      Ich greif mit einem AppleTV 4K aus 2022 und einem AppleTV 4K aus 2017 auf die gleiche VU zu.
      Beim neueren hab ich Picons bei der anderen nicht.
      Ob das am Openwebif liegt? Mmmmm

      Edit:
      OWIF 1.4.0
      Skin: [ linearFHD ] - [ iFlatFHD ] - Anpassungen: [ linearFHD ] - [ iFlatFHD ]

      The post was edited 1 time, last by Nathanael2316 ().

    • jabbela wrote:

      Schreib mir über das Support-Formular auf vuplustv.com eine Nachricht mit deiner Apple-ID.
      Ok hab ich gemacht, danke. Habe nur den einen Account hier. Wenn es mehrere Schrottys gibt hab ich nichts mit denen zu tun.
      * LG OLED65C17LB * VU+ UNO 4k SE * LNB DUR-line UK 124 * SAT TV Unicable * AppleTV 4K mit Ethernet * Router: Fritz!Box 6660 Cable *
    • Nach ca. 1 Woche verwirft die App PIcons in der Cache und versucht die neu zu laden - kann also Zufall sein, dass sie auf dem einen aTV noch da sind.
    • So - eine neue Beta ist auf dem Weg.

      ich habe die Auflösung der PIcons-URLs nochmal überarbeitet und lokal werden sie immer mit dem "Referenz-Name" gespeichert. Wäre schön, wenn das jemand testen könnte, der IPTV nutzt - nicht dass da Probleme mit Sonderzeichen auftreten, die sich unter Umständen in so eine Servicereferenz verirren.

      Ganz neu (weil es auch für mich praktisch war):
      - in den Einstellungen findet man recht weit unten die neue Option "Cache leeren". Damit werden lokal gespeicherte PIcons (auch alte, die nicht mehr genutzt werden) gelöscht. Dazu wird die Verbindung zur STB vorher beendet und danach neu initialisiert. Mit einer vorgesehenen Verzögerung von ein paar Sekunden werden dann die PIcons wieder neu geladen - das kann ein wenig dauern.

      Das war für mich hilfreich, weil ich mit zwei Boxen getestet habe, eine liefert PIcon URLs - die andere nicht.
      Für andere mag es hilfreich sein, wenn sie PIcons auf der Box aktualisieren, zwischen zwei Boxen wechseln oder ähnliches.

      The post was edited 1 time, last by jabbela ().

    • [tvOS] vu+TV App (AppleTV) Support Thread

      Ich hab zwar iptv auch über die vu box aber das läuft mit xstreamity und das ruft der vuplayer nicht ab.
      * LG OLED65C17LB * VU+ UNO 4k SE * LNB DUR-line UK 124 * SAT TV Unicable * AppleTV 4K mit Ethernet * Router: Fritz!Box 6660 Cable *

      The post was edited 1 time, last by Schrotty74 ().

    • Hallo

      Habe seit dem Update das Problem das Kurz nach Umschalten das Bild erst Ruckelt und dann Einfriert.Habe eine Vu+ Duo2

      mit VTi 15.0.02 und ein AppleTV HD also kein 4K. der Ton läuft weiter und das Bild bleibt stehen ??
    • Hallo zusammen,
      habe ein ganz komisches Problem. Ich kann alle Sender problemlos streamen. Aber ARD und ZFF nicht. Über OpenWebIF geht es einwandfrei. Nur über die VUplusTV App nicht. Wie gesagt, alle anderen Sender funktionieren. Hat jemand eine Idee?

      Interessant:
      Habe gerade ARD und ZDF aus einem anderen Bouquet gestartet. Da funktioniert es.
    • ich kline mich auch mal hier ein, da ich einen Bug melden möchte und hoffe, dass dieser gefixt wird:

      - bitte beim zap call unbedingt den url string escapen/encoden: beispiel aus '1:0:19:' soll '1%3A0%3A19' übergeben werden

      ich weiß nicht genau wie aus der App der call aussieht aber da ich davon aussgehe, dass die standard OpenWebIf API genommen wird, ist es wichtig, dass die e2servicereference url escaped wird.

      dh. nochmal

      aus /api/zap?sRef=1:0:19:84:9.....
      soll /api/zap?sRef=1%3A0%3A19%3A84%3A9.....

      steht auch so auf der API Reference: OpenWebif API documentation · E2OpenPlugins/e2openplugin-OpenWebif Wiki · GitHub

      @jabbela

      nutze deine App (ios) bereits seit Jahren und bin total happy damit und möchte dich für deine Arbeit auch mal bedanken!
      Wäre echt nice, wenn du diesen einen Fix noch einbauen könntest :) Thanx!

      The post was edited 4 times, last by durstmick ().

    • @Adeb In dem Zusammenhang ist „neu“ - aber gar nicht so neu - dass die App sich für jeden Sender nicht nur den eingestellten De-Interlacer merkt sondern auch die gewählte Tonspur, sofern man diese manuell geändert hat. Der Stream wird also gestartet und nach kurzer Zeit wird die Tonspur umgeschaltet. Dabei sollte der Stream aber nicht hängen bleiben. Ich werde mal versuchen, ob ich das reproduzieren kann, ich habe ja auch noch das originale aTV 4.

      @durstmick auch das werde ich mir anschauen. Es ist leider nicht immer so logisch, wann man die Referenz escapen muss und wann nicht - es funktioniert leider nicht alles so, wie es dokumentiert ist.
    • Hallo, gibt es irgendeine Möglichkeit bei den Verbindungseinstellungen einen Header zu setzen? Ich würde das ganze gerne mit Cloudflare Tunnels nutzen und dafür muss ich für die authentifizierung einen Header setzen.
    • @nicescream: Ich habe da noch etwas optimiert - aber das grundsätzliche Problem ist erst einmal, dass das VTi-Image eine zu alte Version des OpenWebIF nutzt. Diese liefert mir nicht die URL der PIcon-Dateien, so dass die App diese erraten muss. 1. Versuch ist die Service-Referenz (":" durch "_" ersetzt), 2. Versuch mit dem Sendernamen - aber nur geraten. OpenWebIF kennt ca. 10 Varianten, mit der es PIcons zuordnet - diese kann ich aber nicht alle durchprobieren, weil das eine Unmenge an Anfragen an die Box wären, die den OpenWebIF Server in die Knie zwingen würden.

      @tomatensaft: Die App erstellt bei Anfragen automatisch (wenn angegeben) den Authentication-Header und fügt dort Username und Passwort der Box ein. In deinem Fall würdest du aber wohl Authentication-Header für den Proxy/Tunnel brauchen - und nein, das bietet die App (noch) nicht. Das liegt daran, dass die App eigentlich nicht für die Verwendung außerhalb des lokalen Netzwerkes gedacht ist - und da braucht man dieses nicht. Ich möchte auch nicht unbedingt in Bedrängnis geraten, wenn Betreiber von Pay-TV Sendern der App die Umgehung ihrer Beschränkungen unterstellen.
      Kannst du das Gerät nicht so konfigurieren, dass es automatisch für alle Apps den Tunnel nutzt?
    • Hallo Gemeinde,
      aktuell kann ich keine Aufnahme von der Festplatte meiner 4k SE über die VUplusTV - App auf meinem Apple TV 4K streamen.
      Hat alles schon mal geklappt, allerdings die letzten Aufnahmen funktionieren nur noch direkt an der 4k SE.


      jemand ne Idee ?


      Beste Grüße
      gruss, the foxx
    • Ich habe folgendes Szenario und hoffe sehr, dass mir jemand hier helfen kann:
      Gigablue X3 4K mit OpenAtv 7.2 und OWIF 2.0.5 dient als Server und ein Apple TV 4K 128GB 2022 mit zwei HomePod Minis als Stereopaar, soll über die App als Client dienen.
      Konkretes Problem ist, dass der Ton in 95% der Fälle leicht stottert, Bild ist kein Problem und bis jetzt gefühlt auch unabhängig vom Sender.
      Manchmal „berappelt“ es sich auch nach einer gewissen Zeit aber sobald man umschaltet ist es erstmal wieder da.
      Die App auf einem iPhone 14 Pro macht keine Probleme.
      Ich war vorher auf einem 6.4er Openatv und habe nur in Hoffnung auf Verbesserung geupgradet.
      Aktuell hängt die Box per LAN am dLAN Adapter im Netz und der Apple TV per WLAN. Ich hatte aber auch schon beides direkt im Switch, sodass Bandbreitenprobleme eigentlich ausschließen kann, zumal es mit dem IPhone ja geht.
      Die Suche zeigte Usern mit ähnlichen Problemen aber teilweise viel schlimmer oder sehr alte Beiträge und jeweils ohne Lösung.

      Irgendjemand einen heißen Tipp?
    • @jonnythefoxx: Sind das Aufnahmen von Free2Air Sendern oder von PayTV (mit Verschlüsselung)?

      @Matthes2211: VLCKit hat bei mir Airplay nach wie vor einige Probleme. Ich habe keine HomePods, aber ich kann das sowohl von iPhone, iPad oder aTV reproduzieren, indem ich meinen iMac als Airport-Lautsprecher verwende. Es liegt auch nicht an der Bandbreite aber daran, dass die Audio Ausgabe an Airport von Apple ziemlich abgeriegelt ist. Wirklich gut funktionieren tut es nur, wenn man die offiziellen Frameworks von Apple nutzt. Die können aber die MPEG-TS Streams nicht wiedergeben (definitiv nicht auf aTV).

      Ich hoffe, dass sich das Problem, ein wenig entspannt, wenn sich Videolan beim VLC / VLCKit von OpenGL abwendet. Es gibt von VLCKit 4 eine erste Alpha-Version, die ich mir näher anschauen muss. Es dürfte aber noch ein wenig dauern, bis man sie in einer App zuverlässig einsetzen kann.